Configuring Voice Traffic Support
To configure the way in which the Cisco IP Phone transmits voice traffic, perform this task
Step 1: Router(config)# interface fastethernet slot/port
Step 2: Router(config-if)# switchport voice vlan {voice_vlan_ID | dot1p | none | untagged}
Router(config-if)# no switchport voice vlan
Configuring Data Traffic Support
Step 1:
Router(config)# interface fastethernet slot/port
Step 2:
Router(config-if)# mls qos trust extend [cos cos_value
Router(config-if)# no mls qos trust extend
Step 3:
Router(config)# end
Step 4:
Router# show interfaces fastethernet slot/port switchport
Router# show running-config interfa fastethernet slot/port
Configuring Inline Power Support
To configure inline power support, perform this task:
Step 1:
Router(config)# interface fastethernet slot/port
Step 2:
Router(config-if)# power inline {auto | never}
Router(config-if)# no power inline
Step 3:
Router(config)# end
Step 4:
Router# show power inline [fastethernet slot/port]
Router# configure terminal
Router(config)# interface fastethernet 5/1
Router(config-if)# power inline never
This example shows how to enable inline power on Fast Ethernet port 5/1:
Router# configure terminal
Router(config)# interface fastethernet 5/1
Router(config-if)# power inline auto
Router0
hostname Router0
!
logging userinfo
!
!
enable password cisco
!
!
!
ip dhcp pool phone
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
option 150 ip 10.0.0.1
ip dhcp pool ephone2
network 11.0.0.0 255.0.0.0
default-router 11.0.0.1
option 150 ip 11.0.0.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 11.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface Modem0/0/0
no ip address
!
interface Dot11Radio0/3/0
no ip address
speed 12.0 18.0 24.0 36.0 48.0 54.0 6.0 9.0 basic-1.0 basic-11.0 basic-2.0 basic-5.5
!
interface Dot11Radio0/3/1
no ip address
speed 18.0 36.0 48.0 54.0 9.0 basic-12.0 basic-24.0 basic-6.0
!
interface Ethernet1/0
ip address 192.168.4.1 255.255.255.0
pppoe enable
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
interface Vlan30
mac-address 00d0.ff98.4d01
no ip address
!
ip classless
ip route 192.168.5.0 255.255.255.0 192.168.4.2
!
ip flow-export version 9
!
!
!
!
!
!
!
!
logging trap debugging
logging 11.0.0.3
logging 10.0.0.6
dial-peer voice 2032 voip
destination-pattern 2032
session target ipv4:192.168.4.2
!
dial-peer voice 2033 voip
destination-pattern 2457
session target ipv4:192.168.4.2
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 10.0.0.1 port 2000
auto assign 4 to 6
auto assign 1 to 5
!
ephone-dn 1
number 2456
!
ephone-dn 2
number 2457
!
ephone-dn 3
number 2458
!
ephone 1
device-security-mode none
mac-address 0001.96C3.6B5E
type 7960
button 1:1
!
ephone 2
device-security-mode none
mac-address 0002.4A26.C664
type 7960
button 1:2
!
ephone 3
device-security-mode none
mac-address 00E0.F79B.D114
type CIPC
button 1:3
!
ephone 4
device-security-mode none
mac-address 00E0.8FEA.9761
!
ephone 5
device-security-mode none
mac-address 0001.96A7.94B5
!
line con 0
password cisco
login
!
line aux 0
!
line vty 0 4
password cisco
login
!
!
!
end
Router1
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!
!
!
!
!
ip dhcp pool ephone
network 192.168.5.0 255.255.255.0
default-router 192.168.5.1
option 150 ip 192.168.5.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.4.2 255.255.255.0
duplex auto
speed auto
ipv6 ospf cost 1
!
interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 11.0.0.0 255.0.0.0 192.168.4.1
ip route 10.0.0.0 255.0.0.0 192.168.4.1
!
ip flow-export version 9
!
!
!
!
!
!
!
!
dial-peer voice 2456 voip
destination-pattern 2456
session target ipv4:192.168.4.1
!
dial-peer voice 2457 voip
destination-pattern 2457
session target ipv4:192.168.4.1
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 192.168.5.1 port 2000
auto assign 4 to 6
auto assign 1 to 5
!
ephone-dn 1
number 2031
!
ephone-dn 2
number 2031
!
ephone-dn 3
number 2032
!
ephone-dn 4
number 2033
!
ephone 1
device-security-mode none
mac-address 00E0.8FEA.9761
type 7960
button 1:1
!
ephone 2
device-security-mode none
mac-address 0001.96C3.6B5E
type 7960
button 1:2
!
ephone 3
device-security-mode none
mac-address 0001.42E7.1CB9
type 7960
button 1:4
!
ephone 4
device-security-mode none
mac-address 0001.42CB.CED9
type 7960
button 1:3
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Router1(config)#
Bandwidth Calculator (asteriskguru.com)
No comments:
Post a Comment